Grub problem

I just tried to install MintPPC on a gifted PowerBook G4 (thanks Martin from Austria). I found out the the grub-installer failed to install grub. It is unfortunate that people do not report this. It is possible that MintPPC was not installable for months. If I would have known this, I could have looked at this issue much earlier.

The problem has been fixed.

Published by admin

Developer of MintPPC

Join the Conversation

134 Comments

  1. Just tried using the automated installer on my G4 PowerBook and everything went well until at the very end I got this message: Failed to run presseeded command Execution of reseeded command “in-target export PATH=$PATH:/usr/local/sbin:/usr/sbin:/sbin” failed with exit code 127.
    When I hit “continue” and rebooted everything seemed OK.

  2. I am aware of it. You can disregard the message. The execution of that command works and you don’t need to do it manually afterwards anymore. Welcome back by the way!

    1. I’m a high school Special Education teacher with many dilemmas to deal with. Linux is my escape to something logical and predictable.

  3. I understand, everyone needs an escape. For me it’s also something logical and worthwhile spending free time on it.

  4. I’ve attempted to install Mintppc 32 on an ibook 4g about 10 times without success, the problem seems to be at Select and Install Software. It can fail before finishing, but today it went almost all the way loading 1071 files of 1072 before giving the failure message. I pressed on with the rest, ignoring the error 127 regarding PATH.
    I can now boot in , and enter Username and Password,
    and appear to be in terminal at root. Instructions are to Select Mint-LXDE, Where How ???
    Tomorrow is another day and Hope may triumph over Experience. All suggestions welcomed.

  5. Debian GNU/Linux bullseye/sid debian tty1
    debian login:
    After logging in , at root command ls
    does not appear to do anything
    after cd /usr then ls shows
    bin games include lib libexec local sbin share src
    I have little experience of terminal use, having installed Ubuntu and Mint on old machines. Thanks.

  6. This is not how it should be. If MintPPC would have been installed correctly, you would see a graphical login screen. I would be interested to see the syslog of the installation. Next time you retry, get the syslog of the installation. You will find in the menu to see the installtion log. The computer will act as a webserver and with another computer extract that logfile.

  7. Attempted to install again, the Failure message appeared after Select and Install Software . Its probably not a good idea to repeat a step expecting a different outcome, but I did, again got the Failure message. I continued to the end and Success Success !!!
    I know there are a few adjustments to make for Sound .
    Thanks to all who made this possible.

    1. I think I will have to re-install mintppc 32bit on G4 ibook. When I boot, I see no option for Select Mint-LXDE at log in, one screen shows LDME before moving on to eventually reach the LM logo screen where, after logging in, I see the desktop with Applications in the top right corner and 6 icons bottom centre.

      Web browser does not work with established Wi-Fi Network or Ethernet Network.

      In Libre Office , files can be created in Libre Calc but once saved cannot be opened.
      I’ll try install again as this cannot be correct.

      1. There are icons in the top right corner in the login screen. One of them you can use to change the desktop manager.

        1. After 2 more re-installs , I’m in Arctic Fox on IBook G4 using Mintppc. All appears fine, I’ll test out other applications during the day.
          Great work, Jeroen. It would be a shame to abandon such great looking old computers.

  8. Hi!
    Just tried to install MintPPC on a Mac mini and the grub-installer does not install the bootloader. Tried two times – same result. I’m doing a 32bit install following your instructions closely, partitioning is done automatically for the whole disk.

    Any suggestions what I could do?

    Thomas

      1. Hi there, I get the same result with my Powermac G5 on the 64bit version of the latest image.

        1. Any luck. I am trying to install 64bit on my g5 and get an error saying it couldn’t install bootloader. apologies on the grupo text below it’s copy text from Google lens image.

          “Continue without bootloader

          No boot loader Installed No boot loader has been installed, either because you chose not to or because your speed ific architecture doesn’t support a boot loader get.

          You lll need to boot manually with the boot uminux kernel on partition /dev/sdb3 and root=/dev/sdbs quiet passed as a kernel argument

          Continue

          Tab> moves: selectss Enter activates buttons”

  9. You need to get the syslog of the installation and make it available to the people in powerpc email list.
    https://lists.debian.org/debian-powerpc/
    I am not a specialist in this kind of stuff. Mr Glaubitz in the mailing list should be able to help. In the installation menu (in the Debian installer that is) there is a possibility to make the computer you want to install MintPPC / Debian onto, a local webserver. Another computer can then read out that syslog.

    1. I just read the message there with date november 7 2020. As I’m kind of newbie in Linux & Linux developement, and english is not my native language, I couldn’t understand if it’s already fixed and the files attached there are the new ones. If so, what do we need to do with those files? Thanks in advance.

  10. Just ran into this problem myself with my iBook G4. Can the grub be installed later or is this installation now lost and I must start from scratch when the solution is found?

    Thanks.

  11. You can install Grub later from the installer by doing a ‘rescue’. It is a choice in the Debian installer. You have to wait until this is fixed in Debian.

  12. It seems like the grub problem can be fixed. A new problem has now shown up: the Debian-installer hangs in the partitioning tool partman. People are looking into this problem. This new problem looks a bit more difficult to debug.

  13. I just tried the installation twice on a PowerMac G4 running MacOS X 10.4. When I Instlled MacOS X I left 40 Gb as free space. Installation went ok and the partition manager used that free space perfectly. Then when the GRUB installation stage cam, it failed. As I thought it was because GRUB couldn´t replace MacOS’s boot manager, I installed a second hard drive (yes, I had two 80 Gb IDE HDDs!) and performed installation again. Everything was OK until the GRUB installation that failed again. Then I came here and found out what’s going on! I guess I’ll wait for the bug to be fixed. Sorry about my written english.

  14. I tried installing with 32bit install on Mac Mini G4 PPC and am getting the same Grub install issue. Has there been any updates?

    1. Since their is a grub install issue with this version, is their an older version of MintPPC that I can install? Thanks in advance for the info since I’m new to trying this.

    1. Just so you know, Debian Sid is a mess right now. I just install it from an old installer that used Yaboot instead of GRUB. A base system installed and updated just fine, but when I went to install LXDE using tasksel I got the following, “tasksel: apt-get failed (100)” Dozens of new updates are being uploaded each day lately so they must be revamping everything all at once. As soon as the dust settles they might get around to fixing GRUB but I’m not holding my breath.

    2. Thanks for the info. Is there a way I can install it without getting to the desktop? The nouveau xorg driver and framebuffer do not work with the Nvidia that I have. Debian-installer went fine and I could see the screen perfectly. Only problem is GRUB not installing.
      Thanks in advance and sorry for my english.

    3. A quick and dirty fix, since the issue is hfsprogs:
      When debian-installer fails with grub-install, open a new console (Ctrl+Alt+Fx) and download an older version of hfsprogs. I found one in Fienix.
      cd /target/root
      wget http://fienix.servehttp.com/repos/fienix/soar/pool/main/h/hfsprogs/hfsprogs_332.25-11+b2_powerpc.deb
      chroot /target
      cd /root
      dpkg -i hfsprogs_332.25-11+b2_powerpc.deb
      Go back to the debian-installer and retry a grub install.
      I worked perfectly on my macmini (but I admit it is a dirty hack).

      1. Like I said, they are pushing updates by the dozen as of late. I went back to tasksel and this time was able to install LXDE, and was also able to download all the MintPPC apps. Still no progress on GRUB, though. I’m sticking with Yaboot until they get around to fixing it.

        1. Is there a ppc64 version of this version of hfsprogs anywhere? I’m trapped at the grub install step fail on an imac g5 isight. I booted from iso burned on a cd-r so I cant seem to use apt-src to build it? Does version 540 fix it? I cant find a ppc64 .deb for that either… any more tricks?

      2. Thanks for sharing, David! I’ll give it a try on my G4… By the way, I love dirty hacks! Thanks so much!

      3. I got my G5 as far as the “new console” but being a computer ignoramus who can only blindly follow recipes without knowing what it means I assume my not knowing how to properly input what you shared with us here gives me the result of “-/bin/sh: cd /target/root not found”.
        Admittedly I also would not have known how to get back to the debian installer.

      4. Thanks for this info. I am unable to get a console window: how do I type Ctrl+Alt+Fx on an iBook G4? Is Fx any function key? Because I’ve tried them all and it won’t open a new console, but after the GRUB install fails, it just stays on the Debian Installer Main Menu. Thanks!

      5. Thank you so much for posting this solution David!! I was stumped and about to give up on my installation completely when I saw your solution! I am running a 15″ PowerBook G4 A1138.

    1. I managed to download the file. Don’t know how to get it to incorporate into or replace the bad one in the GRUB boot loader, though. Instructions to that effect are not readily available. Will it require in depth study of Linux programming or could I be directed to a source which will allow me just to follow steps to achieve this?

  15. Have you already suggested a solution for Arne? I would like to benefit from it too, because I feel like him.

    1. Well mano, looks like we’ll just have to surrender to the final obsolescence of our antiquated machinery if even the knowledgeable folks can’t solve this issue. Not a bad thing, really, if you consider you can run a modern pc for a year on the electricity the turbofan space-heater (G5) consumes in an hour.

      1. Arne, you don’t have to surrender, just because GRUB and partman have been broken for months. Yaboot still works and the older version of partman does as well. Follow this tutorial…

        https://forums.macrumors.com/threads/debian-sid-installation-guide-powerpc.2146795/

        But, use this installer image…

        http://cdimage.debian.org/cdimage/ports/10.0/powerpc/

        After updating the /etc/apt/sources.list as directed, do a dist-update to bring everything up to date, install LXDE and MintPPC manually. It works every time. I have MintPPC working just fine on a G4 Quicksilver, numerous G4 Mac minis, and a G4 PowerBook.

  16. Just so you know, the latest installer snapshot, 2021-01-03, partman is still broken.

  17. I´m trying to install it on a G5 iSight and no success so far. GRUB is not installing on the HD. And without GRUB the IMac does not boot into anything, besides this weird IconThing. As you may think now, I am not an expert.

    1. I´m going to try AdéliePPC, maybe this works, even if I would like to install MintPPC more

      1. Before you try another distribution, remember that Yaboot works just fine on these old machines. If you use one of the older installers that installs Yaboot instead of GRUB, you can do a dist-update and then install MintPPC manually as per the excellent tutorial on this site. Works every time…

        1. Does not appear to be designed to work with the G5. From the Yaboot instructions site: https://www.debian.org/ports/powerpc/inst/yaboot-howto/ch2.en.html

          HOWTO-Booting with Yaboot on PowerPC
          Chapter 2 – System Requirements

          Motorola PowerPC processors have been used on at least three different kinds of systems: NuBus, OldWorld PCI, and NewWorld PCI. Nubus systems include the 6100/7100/8100 line of Power Macintoshes. OldWorld systems are most Power Macintoshes with a floppy drive and a PCI bus. Most 603, 603e, 604, and 604e based Power Macintoshes, including the 7200, 7300, 7500, 7600, 8500, 8600, 9500, and 9600 are OldWorld machines. The beige colored G3 systems are also OldWorld.

          yaboot will not work on NuBus or OldWorld machines, those will require quik or (for Mac OS Pre-9.0.4 only) BootX/miboot.

          The NewWorld PowerMacs, for which yaboot is designed, are any PowerMacs in translucent colored plastic cases. That includes all iMacs, iBooks, G4 systems, blue colored G3 systems, and most PowerBooks manufactured in and after 1999.

          1. I wasn’t aware of that. Yaboot works just fine on my gaggle of G4s. Thanks for the information.

  18. I’ve been trying for weeks to get Mint installed on my dual 2-Ghz G5, and have so far had no luck. Between installer failures for an number of things, GRUB will not install, regardless of how I try to do it. I even went as far as making a USB installer stick to try that. I got this done, but for the life of me, cannot figure out how to boot from it.

    Now I hear that some are trying Yaboot instead of GRUB. Anyone had any success with this?

  19. All right…so I have a complete install of Mint, minus the GRUB installation which I would need to boot it from Mac OS X. Is there a way to boot the installation of Mint from the hard drive it is on without relying on GRUB? It seems if I know the Open Firmware command string, it should be simple to force Mint to boot. Correct? Let me know! Thanks!

  20. I tried to install the last PPC64 version from 2021 but here comes the Error Install Grub.Dummy at least it gets further than with older versions. Any Idea ?

    1. It is my opinion that this version of Mint with GRUB is just broken from the get-go, and we are all stuck trying to make it work.

        1. Not exactly. Being unable so far to boot Mint from my hard drive, running anything from a command line in the Rescue environment is iffy, to say the least. The CL won’t let you run many things from the Rescue environment, like Apt, so updating is out of the question.

  21. “Jeroen says: December 25, 2020 at 1:55 pm
    I have been out for a while. Next week after christmas I will have a look at this.”

    Are we left marooned out in ancient Mac purgatory?

  22. Here is a workaround for the GRUB installation problem.

    Use the installer CD-ROM from 4/19/20 and choose Default install.

    When you are told that the GRUB installation has failed, hit Enter and choose ‘Continue without bootloader’, confirm, and once you are given the dialog to remove your install medium and reboot, hit Enter again.

    Reboot the CD-ROM into Rescue mode and when you are asked what device to use as the root file system, select /dev/sda3. Then, execute a shell in /dev/sda3 and input the following commands in order:
    1. apt install grub-ieee1275
    2. grub-install –no-nvram
    3. update-grub
    4. mount /dev/sda2 /mnt
    5. cp /boot/grub/grub /mnt/
    6. umount /mnt
    7. hmount /dev/sda2
    8. hattrib -c UNIX -t “????” :ofboot.b
    9. hattrib -c UNIX -t tbxi :grub
    10. humount
    11. exit
    Reboot the system and install MintPPC manually. Works every time for me.

  23. When you are told that the GRUB installation has failed, hit ESC… sorry about that. Would you edit the above?

  24. Have tried the instructions you have listed above, but as soon as I try to use hfsutils or otherwise try to mount my boot partition, I get an error about the “partition not found (invalid argument)”. My boot partition is sda2, and is 5 GB in size, so there should be no question that it is big enough.

    Any idea what this “partition not found” crap is about?

    1. I went with the guided partition scheme which makes /dev/sda2 128MB. Just as there’s a limit of 2 GB for the swap partition, maybe there’s a limit for the boot partition as well. Also, the boot partition must be formatted as HFS.

  25. Just to be completely sure, I reinstalled Mint from scratch, after reinitializing my hard drive. I have my boot partition as /dev/sda2, at 128 MB, root partition as /dev/sda3, at 70 GB, swap partition as /dev/sda4, at 2 GB. I have 9 GB physical RAM and 160 GB hard drive. After GRUB fails to install at 50%, failing at grub-install DUMMY, I rebooted from CD and loaded the Rescue routine.

    First thing I tried to do was step 4 above. Tried to mount /dev/sda3 on /mnt. This fails, saying “wrong fs type, bad option, bad superblock on /dev/sda2, missing codepage, or other error” /dev/sda2 was formatted as HFS, and it is not too large as said above.

    So, again, at a loss about what to do here. Not sure what else could be wrong. Any direction here would be of great appreciation.

    1. Gary, when you see that the GRUB installation has failed, hit esc and choose ‘Continue without bootloader’, confirm, and once you are given the dialog to remove your install medium and reboot, hit return.

      Then, reboot from the CD-ROM into Rescue mode and when you are asked what device to use as the root file system, select /dev/sda3 . Then, execute a shell in /dev/sda3 and input the following commands in order:
      1. apt install grub-ieee1275
      2. grub-install –no-nvram
      3. update-grub
      4. mount /dev/sda2 /mnt/
      5. cp /boot/grub/grub /mnt/
      6. umount /mnt/
      7. hmount /dev/sda2
      8. hattrib -c UNIX -t “????” :ofboot.b
      9. hattrib -c UNIX -t tbxi :grub
      10. humount
      11. exit
      Then, reboot…

      1. I too also get an error when trying to mount /dev/sda2 /mnt
        This fails, saying “wrong fs type, bad option, bad superblock on /dev/sda2, missing codepage, or other error”
        So it clearly is not just an isolated issue. I’ve tried to follow your steps multiple times and /dev/sda2 cannot be mounted, period.

          1. Of course my boot partition is named sda2, as indicated by the installer, and further, it is formatted as HFS. I believe GRUB is farked up beyond all repair in this installation, and won’t likely be repaired anytime soon. It seemed to be going so well, but it looks like I will be searching for a better Linux distro to install on my G5 DP.

          2. I only say that because the boot partition on some old machines might be called /dev/hda2 or as it is called on my G4 Quicksilver with 2 drives, /dev/sdb2.

  26. I’m not sure if anyone else had the same problem as me, but my mintppc wouldn’t boot automatically. I had to enter OpenBios and type “boot hd:2,\grub”.

    I solved it by using this command:
    nvram –update-config boot-device=hd:2,\grub

  27. Thomas, this is exactly what I have done: hit Escape when GRUB failed to completely install, rebooted into the Mint Installer CD, load the Rescue routine, load a shell in /dev/sda3, and try to run the steps above. I am as yet unable to mount my boot partition (/dev/sda2) by any means, including what you have listed above. Something is happening to the boot partition to make it unable to be seen for mounting or use.

  28. I tried the late December and January images. Both failed GRUB install for me on an iBook G4. However, I believe this is due to the powerpc-ieee1275 modules not being loaded in the installer grub image. This is why I state that. When I reboot with the MintPPC install disk and kick out to the GRUB CLI prompt, I don’t see the apple partitions when I type “ls”, (ex: ieee1275/hd, apple3).
    I was able to boot with a live CD/DVD from Adelie (which I never got to install), that did list all of the apple partitions.
    I did the following to boot to my MintPPC install:
    From GRUB CLI:
    set root=(ieee1275/hd,apple3)
    linux /boot/vmlinux-5.5.0-2-powerpc root=/dev/sdb3
    initrd /boot/initrd.img-5.5.0-2-powerpc
    boot

    Once I was in and I had the network connected, I did the following:
    apt-get install grub2
    grub-install /dev/sda
    update-grub (Needed each time you customize your grub.cfg file)

    If you unfortunately had yaboot installed, you can do the following:
    Mount your boot_strap partition and change all references to yaboot to grub.
    mkdir /mnt/bs
    mount /dev/sda2 /mnt/bs
    cd /mnt/bs
    rm yaboot
    rm yaboot.conf
    cp /boot/grub/* /mnt/bs
    Use “nano” or “vi” to edit the ofboot.b file and change all instances of yaboot to grub.
    Cross your fingers and reboot.

    This worked for me. I now have a graphical GRUB 2 boot loader.

  29. Have you tried going back to Yaboot instead of GRUB? If you use this installer: debian-10.0-ppc64-NETINST-1.iso update your sources.list, and do a dist-upgrade, you can then go on to manually install MintPPC. I do it all the time on my dual-boot G4 Power Macs.

    1. Hey Thomas,

      Can you point me a link with steps, if possible? I really want to get linux mint on the machine.

      Thanks, Mark

        1. So I actually installed lubuntu. I thought I read that was viable too,but I guess not:
          The following packages have unmet dependencies:
          mint-common : Depends: gir1.2-xapp-1.0 but it is not installable
          E: Unable to correct problems, you have held broken packages.

          1. Lubuntu has a completely different sources scheme than Debian 10. I’m not surprised that you had unmet dependencies.

    2. So I was able to get Debian installed with grub using a combination of this post: https://forums.macrumors.com/threads/debian-sid-installation-guide-powerpc.2146795/post-29677631, your comments on using the live cd to fix grub, and finally using the live cd and method Shannon Bell used above.

      In the macrumours post they indicated the versions listed here under the snapshot directory fixed the repo issue with missing GPG key and grub: https://cdimage.debian.org/cdimage/ports/snapshots/

      That said, I still did run into many issues. For one, not everything needed was installed, the account credentials (both root and user) did not work when I finally able to get to a login prompt and grub didn’t work.

      1. I installed the latest snapshot and it was able to complete installation -although security repo failed.
      2. I booted into debian using Shannon’s comment on the live cd but with init=/bin/bash at the end of vlinux kernel command, so I could get into single user mode.
      3. Executed mount -o remount,rw / so I can make changes via root
      4. updated both root and user passwords after mount -r
      5. used both live cd from Shannon and Thomas’s commented to update/upgrade the system, which after being persistent on fixes repo was able to properly install grub

      However, after all of that when I run the install command for the mintppc repo I get unsupported architecture. Please tell me ppc64 is supported.

    1. I think I tried this one but it had grub bootloader:
      debian-10.0-powerpc-NETINST-1.iso 2018-05-1

      1. Go back to the parent directory and click on 10.0, then go to either powerpc or ppc64. Both install Yaboot instead of GRUB. After installation and reboot, install sudo from the cd-rom, do a usermod -aG sudo USERNAME, and also install openssh-server. That way to can login from terminal on another machine and copy and paste the correct sources into /etc/apt/sources.list from the tutorial.

        1. Okay, I am installing the 10 version with yaboot. Question, on the package manager installation it is asking for a mirror. On the other versions it gave me a few mirrors (e.g. Germany), but on both the 9 and 10 yaboot version I only have “enter” manually. I have tried a few without success. Do you know what I can put in?

          1. Almost ready to give up. The version of Debian 10 which has grub only as a bootloader has the mirrors that populate (germany/Korea). I took the same mirrors and applied it to the version of Damian with yaboot and it cannot download the necessary file. I allowed it to finish the installation but Yaboot fails to boot the installation with a file system error.

          2. When using the Debian 10.0 installer, proceed as usual until you asked for a mirror. Then, arrow key Go Back and answer Yes to continue without a network server. Install the Standard Utilities, Yaboot will install, and your cd-rom will eject. Push it back in again and reboot. Login as root and install the apps I suggested from the cd-rom. Like I said, its much easier to ssh into your fresh install from another computer. Change the /etc/apt/sources.list according to the tutorial and delete the cd-rom entry. You will have to do sudo apt install debian-ports-archive-keyring in order to sudo apt update and then do a sudo apt dist-upgrade to bring everything up to date. Then you can manually install MintPPC.

  30. I was able to install the 32bit powerpc Adélie Linux 1.0 RC2 on my Pismo PowerBook G3, noting the following:
    1) It installs GRUB 2.04 very smoothly with OF finding and booting GRUB without any issues.
    2) Adélie Linux 1.0 RC2 runs OK via the CLIBUT it does not support ATI Rage Mobility 128 graphics and so X Window does not run…….

    1) Is there any way that the Adélie Linux way of getting GRUB installed can be used with MintPPC?

    2) Or, is doing a MintPPC remix of Adélie Linux 1.0 RC2 possible/feasible, so that ATI Rage Mobility 128 graphics can be supported?

    3) Can a Debian MintPPC installer CD iso offering the option of either installing Yaboot or GRUB booting be compiled?

  31. So I found a different way of installing. I am not able to boot from usb. I have tried with little success. I a sure it can be done, but I haven’t been able to so far. Here is my method to getting this installed via the live img:

    1. Download image from this site.
    2. untar it so it only has the .img at the end.
    3. On a working Mac burn the img to your drive (hd/ssd)
    a. Connect your drive to a usb to sata (what I am doing) or the drive connected to a sata port.
    b. Format the drive with disk utility (APM/mac extended)
    6. Burn the image to the disk: sudo dd if=/path-to-image/mintppc64-live.img of=/dev/disk
    7. Using a live DVD such as Adélie boot up to the desktop
    set root=(ieee1275/hd,apple3)
    linux /boot/vmlinux- root=/dev/sda3 (assuming sda if only drive)
    initrd /boot/initrd.img
    boot
    8. Login fix your network interface ip, gateway, resolv.conf if needed.
    9. Perform apt update
    10. Here you can do either grub-install/update-grub as root and sudo apt install –reinstall grub2.

    For number 10 I am not sure if one or the other will be sufficient bot after I did these steps I had a working graphical grub.

    1. should be for line 6.
      6. Burn the image to the disk: sudo dd if=/path-to-image/mintppc64-live.img of=/dev/disk<your disk number)

    2. After, you can use gparted after swapoff linux-swap, extended your root sda3, and if you need, create a new linux-swap.

      1. Mark, mind telling me what is in your /etc/apt/sources.list file when you done installing? Why I’m asking is that part of the problem with using the automated install method is that it defaults to the deb.debian.org repository instead of the correct one at http://ftp.debian.org where the latest version of grub-ieee1275 is located.

        1. I have provided output below. I keep debian repos disabled unless I need to install something outside of the mint.nl repo.

          # deb cdrom:[Debian GNU/Linux 10.0 _Sid_ – Unofficial ppc64 NETINST 20200419-15:29]/ sid main

          #deb cdrom:[Debian GNU/Linux 10.0 _Sid_ – Unofficial ppc64 NETINST 20200419-15:29]/ sid main

          #deb http://deb.debian.org/debian-ports sid main
          #deb http://deb.debian.org/debian-ports unreleased main
          #deb [arch=all] http://ftp.debian.org/debian/ unstable main contrib non-free
          # deb-src http://deb.debian.org/debian-ports sid main

          # ‘unreleased’ does not support sources yet
          # deb-src http://deb.debian.org/debian-ports unreleased main

          ## MintPPC64 repository
          deb http://u58733p55594.web0093.zxcs-klant.nl/repo-64 unstable main

          # This system was installed using small removable media
          # (e.g. netinst, live or single CD). The matching “deb cdrom”
          # entries were disabled at the end of the installation process.
          # For information about how to configure apt package sources,
          # see the sources.list(5) manual.
          ~
          ~
          ~

        2. #

          # deb cdrom:[Debian GNU/Linux 10.0 _Sid_ – Unofficial ppc64 NETINST 20200419-15:29]/ sid main

          #deb cdrom:[Debian GNU/Linux 10.0 _Sid_ – Unofficial ppc64 NETINST 20200419-15:29]/ sid main

          #deb http://deb.debian.org/debian-ports sid main
          #deb http://deb.debian.org/debian-ports unreleased main
          deb [arch=all] http://ftp.debian.org/debian/ unstable main contrib non-free
          #deb-src http://deb.debian.org/debian-ports sid main

          # ‘unreleased’ does not support sources yet
          #deb-src http://deb.debian.org/debian-ports unreleased main
          deb http://ftp.ports.debian.org/debian-ports/ sid main
          #powerprogress

          deb [arch=ppc64] https://repo.powerprogress.org/debian sid main

          ## MintPPC64 repository
          deb http://u58733p55594.web0093.zxcs-klant.nl/repo-64 unstable main

          # This system was installed using small removable media
          # (e.g. netinst, live or single CD). The matching “deb cdrom”
          # entries were disabled at the end of the installation process.
          # For information about how to configure apt package sources,
          # see the sources.list(5) manual.
          ~

  32. Hi there,
    I succeeded in installing the latest debian version without any distribution, just cli, via expert install. GRUB2 works fine.
    After editing the sources.list and apt-get update i get an error concerning the public key of the mintlinux source (just ppc not ppc64). I ended up with /repo. Does anyone know, what to do now? By the way, how do i install mintlinux manually?

    Thanks and regards
    Markus

  33. Ok, hello everybody.
    I’ve spend hours and hours trying to install mintppc on my old powerbook (12”, G4 processor 1250 RAM).
    I am stack, however, on a step that nobody seems to mention…Let me clarify
    1) I follow the “Installation with live USB” peocedure, my drive is not functional
    2) I managed to boot from the live usb that I made. I used “boot usb0/disk@1:2,\grub” to boot. So far so good.
    3) O load mintppc live fine. Then I used “dd if=/path/to/mintppc-live.img.gz | gunzip | dd of=/dev/sda” to write image to my disk (sda is my disk)
    4) After this is completed (I get a message “gzip: stdin: unexpected end of file”), I start gparted. So far so good
    5) I move swap partition and increase sda3 size….everything seems fine. ,,and here comes the strange part.
    6) I reboot from disk. I see nothing but a solid gray screen with a folder icon in the middle, which changes every about one second. The folder displays a question mark, and then the MAC “finder” app symbol….that is all

    does anyone else seen this before?

    thank you in advance

  34. What happens if you boot with the option key (alt) hold down ? Don’t you get to see a bootable device ?

  35. Hello.
    If I try booting while pressing the “option” key, I get a blue screen. The blue screen has 2 grey buttons.
    The left button has a symbol like “refresh”. If I press it, it seems like searching for something, then it stops.
    The right button has a “right arrow” symbol. If I press it, is does nothing.

  36. Hi again,
    I repeated the procedure again, so as to be sure.
    The problem is the same.

  37. hi again!
    I thought It would be a good idea to provide some screenshot, in order to show step by step what I did:
    1) At first, I followed the instructions, I created a live USB, and I booted from this.
    https://imgur.com/LuWqwWd
    2) Those are my disks, while I am in live USB
    https://imgur.com/cf95C8U
    3) This is my hdd in powerbook. No partition there
    https://imgur.com/1geaPzZ
    4) I create a partition table (don’t know if this is necessary)
    https://imgur.com/dgCB9O1
    5) I plugged my second USB drive, meaning the one that has the image copied. In picture this is scd
    https://imgur.com/wSGyFL8
    6) I executed the “dd” command (yes, it took some time…)
    https://imgur.com/Yy9mdWW
    7) command is completed
    https://imgur.com/6rVzpvc
    8) New status of my hdd
    https://imgur.com/z9n4Ye7
    9) My hdd in gparted, before changes
    https://imgur.com/eciQxbQ
    10) I move SWAP to the end and I increase root size
    https://imgur.com/cqNEJ0b
    11) This is my screen after reboot (from hdd)
    https://imgur.com/4fedADZ
    12) and this is my screen if I boot pressing ‘command’
    https://imgur.com/WX4BTMh

    I hope this helps 🙂

    1. i thought flash drive was the normal way… what method is network installer, automated?

  38. Hello, I attempted this on a powerpc g4 1.42 after having trouble with lubuntu on it (in lubuntu the system would freeze up after a couple minutes, even in the live version, but also after successful install… looked good though!). SO… two days of attempting to install: in between partitioning and installing base system would enter a never-ending loop in which it kept saying it needed partitioning, i would partition, then it goes to re-detect the partitions because before installating the base system it checks the partitions. It would actually change my partitions in this process (taking number 2 from 256MB to 1MB), eventually i aborted the installation thinking I could re-install from the beginning but now i can’t even load OF, so i guess it’s a brick. Great installer!

      1. Kevin, my experience with a G4 Power Mac MDD is that the dual-processor machines are not supported very well. It’s almost impossible to get a working GUI on them, while everything works fine on my single-processor G4 (MDD 2003) machine. Also, installing LXDE with tasksel has been broken for weeks. The best way to manually install MintPPC is to first install a bare system using the 02/02/2001 installer and then install lxde-core, then install the rest of the MintPPC stuff. Works for me every time.

  39. hi again,

    I tried the net method. I noticed the following:
    1) In the instructions regarding booting from USB something is wrong…I think you should include something like “how to make devalias”..anyway, I managed (don’t quite understand how) to make it boot :)))))
    2) the preseed file “http://u58733p55594.web0093.zxcs-klant.nl/d-i/mintppc32/preseed.cfg” seems not to exist. I started non-automated procedure….still trying…..

    hope this helps
    andreas 🙂

  40. Hi again.
    I am happy and confused…. 🙂
    As I mentioned in my previous post, I started the Network procedure.
    Despite problems 1) & 2) I mentioned, procedure was fine…..at least that what I thought!
    I created the partitions…I installed the packages (it took some time)….and….DONE!
    I rebooted, and what I see is….a nice Debian11 xfce environment 😀
    OK, seriously, I cannot understand what was wrong…I was supposed to see a mint environment, right?(and YES, I used the .iso provided in the instructions).
    So…what happened??? 😀

  41. Did you type the correct path to the preseed file? If not, you install plain Debian.
    If you login, at he login screen you have to select a mint-lxde session, otherwise you will not be able to see MintPPC.

    1. I tried this one, several times
      “http://u58733p55594.web0093.zxcs-klant.nl/d-i/mintppc32/preseed.cfg”
      it was not working….
      I cannot see the “mint-lxde session”. Maybe because I installed debian 🙂

  42. Thomas, can you try an installation and tell us how you get it to install?

Leave a comment

Leave a Reply to Ray Woodhouse Cancel reply

Your email address will not be published. Required fields are marked *