MintPPC for G5 not working yet

Yesterday it was “saxfun” in the Macrumors forum who successfully installed MintPPC for the first time on his PowerBook G4. It shows that the MintPPC installation image for G3 and G4, which is 32-bits, works well. Another person (MacBoer on the same forum) tried the 64-bits image on his G5 iMac but he was unsuccessful. This result was to be expected as the MintPPC repository only has 32-bits packages at the moment. I am working to build the architecture specific MintPPC packages on my iMac G5. I have to first get a working Debian sid on this machine. Luckily, the same person who tried to install MintPPC on his G5, was finally able to install ppc64 Debian sid with some help. We now know how to do it. Apparently there is a problem with 64-bits yaboot. Said package cannot handle kernels which reside on ext4. Switching to ext3 was the solution. I will in due course adapt the installation instructions page to make installations on G5 successful as well.

When the installation of MintPPC on G5 works out of the box I will write another blog post to announce it. I will then have updated the Installation instructions page. So please be a little bit patient as MintPPC for G5 is coming…

Published by admin

Developer of MintPPC

Join the Conversation

3 Comments

  1. I did a test today. It seems that the Debian-ports archive has been improved since the transition to a new version of perl. I only encountered two dependency problems which I may have to fix myself. I am getting closer to MintPPC/64.

  2. I was trying to follow this: When you want to install the yaboot bootloader on G5, do the following. Continue without Grub bootloader. Let is all finish, reboot and start up from the MintPPC image again. Now use ‘rescue’. You will be asked where your root resides, this is /dev/sda4. Mount the /boot partition.We are going to install yaboot manually now. Enter ‘Execute a shell in /dev/sda4’ and do the following:

    yabootconfig -b /dev/sda2
    ybin -v
    exit

    This command even work…..
    Should perform something else?

  3. Dear evgeniy,
    I don’t understand your question. I guess you mean that it worked. Please exit and go back to the menu and select “Finish the instalaltion”
    Please ask questions in the forum. It is so much easier to spot questions as compared to adding comments in blog posts.

Leave a comment

Leave a Reply to evgeniy Cancel reply

Your email address will not be published. Required fields are marked *